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         Twin Tec User Instructions for 
PC Link Evo Software 

CAUTION: CAREFULLY READ INSTRUCTIONS BEFORE PROCEEDING.  
NOT LEGAL FOR USE OR SALE ON POLLUTION CONTROLLED VEHICLES. 

OVERVIEW 
PC Link Evo software runs under Microsoft 

Windows 98/ME/XP/Vista. The Evo version of PC link 
software allows the user to program our ignitions for 
Evolution® series engines with custom advance tables 
and other engine parameters. These ignitions use the 
brown tachometer wire for the link to a laptop 
computer. An optional USB Interface or PC link cable 
is required.  

The new Twin Tec USB Interface P/N USB-INTF 
provides PC connectivity for all of our engine controls 
(ignition and fuel injection systems) and eliminates the 
requirement for multiple cables or a separate USB 
adapter if your laptop is not equipped with an RS-232 
serial port (9 pin male D-sub connector). The USB 
Interface is compatible with Windows 98/ME/XP/Vista. 

If you do not have the new USB Interface, you 
will require the original RS-232 PC link cable P/N 
1005-C. 

Please note that PC Link Evo cannot access 
restricted private label products other than those 
authorized. 

PC REQUIREMENTS 
If you are using the new Twin Tec USB Interface 

(P/N USB-INTF), refer to the supplied instructions for 
details. No additional hardware is required.  

The original PC link cable connects to an RS-
232 serial port by means of a female 9 pin D-sub 
connector. Data transfer occurs at 56 kBaud. The high 
baud rate limits the maximum cable length and the use 
of an extension cable is not recommended. Due to the 
cable length limitation and the need for portable 
access, a laptop PC is recommended. The PC must 
have a free serial port (COM1-255) with a standard 9 
pin male D-sub connector. If your laptop does not 
include a serial port, you can use a USB adapter. 
However, not all USB adapters will work correctly with 
our PC link cables. Most of the inexpensive USB 
adapters are intended for interfacing Palm Pilot type 
devices and do not support all the signals required by 
our PC link cables.  

We sell and recommend a low cost USB adapter 
(P/N USBG-232) that has been tested with a wide 
range of system configurations. The USBG-232 
adapter comes with correct and updated driver files on 
CDROM. After installation the USBG-232 adapter will 
usually appear as COM5. 

We recommend a laptop with Pentium processor 
and super VGA display (SVGA with 1024 x 768 pixel 
resolution) running Windows 98/ME/XP/Vista. Data 
chart display is graphics intensive and a high speed 
Pentium processor is recommended. Processors 
slower than 300 MHz will exhibit sluggish program 
loading and response. The PC must have a CDROM 
drive for program loading.  

PC Link Evo includes a print command that 
prints advance table graphics and other engine 
parameters. The program has been tested with 
Hewlett-Packard laser and inkjet printers and Epson 
inkjet printers. We recommend using a color inkjet 
printer.   

SOFTWARE INSTALLATION 
The software is supplied on CDROM media or in 

the form of a compressed file downloaded from our 
website. The installation process uses InstallShield. 
This industry standard installer is based the new 
Microsoft Windows Installer service that greatly 
reduces potential problems such as version conflicts 
and allows for application self-repair. Since Windows 
98 systems did not originally include the Windows 
Installer service, the required installer software is 
included in the distribution media.  

Before proceeding with installation, shutdown 
any other applications that may be running. For 
Windows Vista, you must disable the User Account 
Control (UAC) during installation. If you are not familiar 
with the UAC, please refer to the Vista UAC Tech Note 
on our website's Tech FAQ for details. 

Use the Windows Explorer or the Run command 
from the Windows Start Menu to launch setup.exe in 
the PC_Link_Evo folder on the CDROM or the 
setup.exe file downloaded from our website. 
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InstallShield will install the software in an appropriate 
folder under Program Files. 

The PC_Link_Evo.cfg file contains access codes 
for restricted private label products. You will only be 
able to access those products for which this file 
contains valid access codes. 

Once InstallShield has completed the 
installation, PC Link Evo will appear on the Windows 
Start Menu. You can then launch it just as you would 
any other Windows program.  

PC Link Evo requires the Monospace 821 BT 
fixed pitch printer font in order to properly align 
columns when printing advance tables. The 
Monospace 821 BT font is included in the distribution 
media and automatically copied to your Windows Fonts 
folder during installation. A backup copy is also placed 
in the program folder. If you accidentally delete this 
font, use the Install New Font command from the Fonts 
folder File menu. The filename associated with 
Monospace 821 BT is monos.ttf.      

SOFTWARE OPERATION 
After PC Link Evo is launched, the main screen 

appears blank. You have three options for obtaining 
advance table data for editing. You can open a 
previously saved advance table file by using the Open 
Table command on the File menu, create a new table 
by using the New Table command on the File menu 
(refer to Figure 1), or download data from an attached 
Twin Tec module by using the Download From 
EEPROM command on the Communications menu. 

Note that advance table data files use a .tbl 
extension. Create a separate folder to store these files.   

Once you have advance table data, you can edit 
the data by clicking on and dragging individual points 
on the chart display (refer to Figure 3) or you can 
directly edit numeric data on the spreadsheet grid.  

After you have completed editing the advance 
table data, you can display and edit the associated 
engine parameters by using the Edit Module 
Parameters command on the Edit menu (refer to 
Figure 4).  

Figure 1 - Creating a New Advance Table 
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Once the appropriate parameters have been 
entered, you can print the data using the Print Table 
command on the Print Menu. You can save the edited 
advance table by using the Save Table command on 
the File menu.  

You can upload the advance table data and 
engine parameters to an attached Twin Tec module by 
using the Upload to EEPROM command on the 
Communications menu.   

CREATING A NEW ADVANCE 
TABLE  

Use the New Table command on the File menu. 
The dialog box shown in Figure 1 appears. You will be 
prompted to select the table type: Race for the 
standard version or EX for the limited advance range 
version. You can enter an advance slope switch 
setting. Each time you click on Update, the 
corresponding advance table is displayed. The 
advance values are exactly what the Twin Tec module 
would interpolate from the factory programmed 
minimum and maximum race advance tables in FLASH 
memory with the same switch setting.  

You will find the New Table command useful for 
generating an advance table that will serve as a 
starting point for further edits. When you are ready to 
proceed with editing, click on OK.  

The New Table command is also useful for 
checking out exactly what advance would be 
generated for any given switch setting.  

Module parameters are not changed when you 
create a new advance table. Always check the 
module parameters after you create a new advance 
table.  

Editing Table Data 
You can edit table data using standard Windows 

copy and paste operations by selecting cells and then 
clicking the right mouse button to pop-up the edit 
menu. You can select cells by dragging the mouse with 
left button down. You can also use the Modify 
command on the pop-up menu.  

Figure 2 – Modify Command  

 

When you enter a value, the presence of 
optional sign (+ or -) or percent (%) characters affects 
the outcome of the Modify command.   

Chart Operations 
PC Link Evo is intended to be an open system 

and uses the Component One Chart 7.0 2D charting 
control. The adventurous user can experiment with the 
chart property pages by right clicking on the chart. 
Almost any chart property can be changed. Click on 
the Help button for more information. If you corrupt the 
chart, exit and restart PC Link Evo.  

Data Export and Import by Means of Drag 
and Drop 

You might want to export or import table data 
to or from another application such as Microsoft Excel. 
Arrange the program windows so that both the source 
and destination are visible (one on the left side of the 
screen and the other on the right side seems to work 
best). You must be able to see the information you 
want to drag as well as the location where you want to 
drop it. To export from PC Link Evo to Excel, use the 
left mouse button to select a range of data on the 
spreadsheet grid. Then move the mouse cursor to an 
edge around the selection. Hold the left mouse button 
down and drag the selection into Excel. Release the 
left mouse button on the top left cell in Excel. When 
importing into PC Link Evo from Excel, use the same 
procedure, except that Excel requires dragging and 
dropping with the right mouse button.   

DOWNLOADING DATA FROM 
EEPROM  

If you are using the new USB Interface, refer to 
the supplied instructions for details. No additional 
hardware is required.  

If you are using the original RS-232 PC link 
cable, connect the cable to the ignition and PC serial 
port. Connect the Packard Weather Pack connector at 
the end of the cable to the brown tachometer wire from 
the ignition module and connect the black alligator clip 
to a good frame ground.  A mating Weather Pack plug 
is already installed on our externally mounted plug-in 
modules and supplied in the parts bag for internally 
mounted (nose cone) modules.  

Turn the ignition key and engine run/stop 
switches on to provide power to the ignition. Do not 
start the engine. 

If the engine or ignition has been removed from 
the motorcycle, you can do bench top testing by using 
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an adapter harness (P/N EVO-ADAPT) that includes a 
small 12 volt DC power supply.  

COM1 is used as the default port. If you are 
using a different COM port, use the Port Setup 
command on the Communications Menu. 

Download data by using the Download From 
EEPROM command on the Communications menu. If 
you attempt to access a restricted private label module, 
the program will display a warning message and abort 
the download process. Otherwise, the program will 
display the module's firmware ID. 

If the download process is successful, the 
advance table data will be displayed for editing. 
Module parameters (explained further on) are also 
downloaded and can be displayed using the Edit 
Module Parameters command on the Edit menu.  

Twin Tec units are shipped from the factory with 
a default advance table loaded into EEPROM memory. 

This is the same as the race maximum advance table 
stored in permanent FLASH memory. If you have 
never uploaded any custom advance table to 
EEPROM memory, this default table is what you will 
see.  

Please note that no relationship exists between 
the advance data downloaded from EEPROM and any 
switch settings on the module. Also note that the 
minimum and maximum advance tables stored in 
FLASH memory are permanent and cannot be 
changed or directly accessed.  

EDITING ADVANCE TABLE DATA  
Once you have advance table data, you can edit 

the data by clicking on and dragging individual points 
on the chart display (refer to Figure 3) or you can 
directly edit numeric data on the spreadsheet grid.  

 

Figure 3 - Editing Advance Data 
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The table consists of 16 columns corresponding 
to 500 RPM increments from zero to 7,500 RPM and 2 
manifold pressure (MAP) rows corresponding to low 
manifold pressure (high vacuum - VOES switch closed) 
and wide open throttle (VOES switch open). The 7,500 
RPM advance value is used at all higher RPM levels.  
In most cases you will only edit the wide open throttle 
(WOT) curve. Advance values must be between zero 
and 40 degrees. 

At higher RPM values, the WOT and low MAP 
curves may overlap. If you click on a chart point where 
the curves overlap, the WOT curve has priority and will 
be selected. If you need to edit the low MAP curve, 
enter the data in the spreadsheet grid.   

Editing Table Data 
You can edit table data using standard Windows 

copy and paste operations by selecting cells and then 
clicking the right mouse button to pop-up the edit 
menu. You can select cells by dragging the mouse with 
left button down. You can also use the Modify 
command on the pop-up menu. When you enter a 
value, the presence of optional sign (+ or -) or percent 
(%) characters affects the outcome of the Modify 
command as shown in Figure 2.   

Chart Operations 
PC Link Evo is intended to be an open system 

and uses the Component One Chart 7.0 2D charting 
control. The adventurous user can experiment with the 
chart property pages by right clicking on the chart. 
Almost any chart property can be changed. Click on 
the Help button for more information. If you corrupt the 
chart, exit and restart PC Link Evo.  

Data Export and Import by Means of Drag 
and Drop 

You might want to export or import table data to 
or from another application such as Microsoft Excel. 
Arrange the program windows so that both the source 
and destination are visible (one on the left side of the 
screen and the other on the right side seems to work 
best). You must be able to see the information you 
want to drag as well as the location where you want to 
drop it. To export from PC Link Evo to Excel, use the 
left mouse button to select a range of data on the 
spreadsheet grid. Then move the mouse cursor to an 
edge around the selection. Hold the left mouse button 
down and drag the selection into Excel. Release the 
left mouse button on the top left cell in Excel. When 
importing into PC Link Evo from Excel, use the same 
procedure, except that Excel requires dragging and 
dropping with the right mouse button.   

MODULE PARAMETERS  
Module parameters are displayed in a dialog 

box, as shown in Figure 4, by using the Edit Module 
Parameters command on the Edit menu. Module 
parameters control the overall operation of the Twin 
Tec module.  

When PC Link Evo is first started, default 
module parameters are loaded. Module parameters 
are updated whenever you download data from an 
ignition module or open an advance table file. Module 
parameters are saved along with the advance table 
data when you save an advance table. Always check 
the module parameters before uploading data to an 
ignition module. 

Under Options, you can select either EEPROM 
Advance Table or FLASH Advance Tables.  

You must select the EEPROM Advance Table 
option in order to force the Twin Tec module to use a 
custom advance table. If you make this selection, the 
unit will use the advance values stored in the EEPROM 
based table, subject to any initial timing or rear cylinder 
offset. The advance slope switch will become inactive. 

If you select the FLASH Advance Tables option, 
the unit will use the factory programmed minimum and 
maximum advances tables in permanent FLASH 
memory and interpolate between these two tables 
based on the advance slope switch setting. 

Figure 4 - Editing Module Parameters 
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Regardless of the advance table selection, you 
can also select the Fixed RPM Limit and/or Alternate 
Use of VOES Input for Retard options. If you select 
one of these options, the corresponding slider control 
appears and allows you to enter a value. These 
options are primarily intended for engine builders and 
tuners. A fixed RPM limit overrides any RPM limit 
switch setting.  

The Alternate Use of VOES Input for Retard 
option is intended for specialized turbocharger and 
nitrous oxide injection applications. When this option is 
selected, the unit will retard timing up to 10 degrees if 
the purple /white VOES wire is grounded.   

The Kick Start Mode option is only applicable to 
Revision 7.0 and higher Model 1005 ignitions. When 
this option is selected, the ignition will immediately fire 
a spark when the engine is kicked over. 

Cranking Revs sets the number of engine 
revolutions before the ignitions fires the first spark. 
Most Evolution engines will start best with a setting   
of 2. Please note that a hot engine may exhibit 
preignition and appear to start on the first revolution 
even if the Cranking Revs parameter is set to a non-
zero value.  

You can also adjust the rear cylinder timing 
offset over a -5 to +5 degree range. Leave the slider 
midrange at zero if you do not require a rear cylinder 
timing offset. 

Please note that the retard and rear cylinder 
offset values are read out directly in degrees.  

UPLOADING DATA TO EEPROM  
Refer to the Downloading Data from EEPROM 

section on page 3 for details about USB Interface or 
PC link cable hookup and COM port setup. Before 
uploading, make sure the module parameters are 
correct. If you want the module to use a custom 
advance table, you must select the EEPROM 
advance table option as explained on page 5.   

Upload data by using the Upload To EEPROM 
command on the Communications menu. If you 
attempt to upload a race version file to a Model 1005 
EX unit or attempt to access a restricted private label 
module, an error message will appear and the upload 
will be aborted. A status message is displayed when 
the upload process has been successfully completed. 

 

 

MODULE SWITCH SETTINGS  
When you upload data, you do not have to 

change any module switch settings.   

Mode. If you select the EEPROM Advance 
Table option in the Module Parameters dialog box prior 
to uploading, the mode switch no longer controls 
advance selection (i.e. street or race). The mode 
switch still selects dual/single fire and multi-spark. If 
you change coil type or multi-spark, you can use the 
following mode switch settings: 

0  Dual fire, multi-spark disabled 

1  Dual fire, multi-spark enabled 

2  Single fire, multi-spark disabled 

3  Single fire, multi-spark enabled 

 

Advance Slope. If you select the EEPROM 
Advance Table option in the Module Parameters dialog 
box prior to uploading, the advance slope switch is 
disabled.  

RPM Limit. If you select the Fixed RPM Limit 
option in the Module Parameters dialog box prior to 
uploading, the RPM limit switches are disabled.   

TROUBLESHOOTING FLOWCHART 
Follow the troubleshooting flowchart on the next 

page. Experience has shown that most communication 
problems are user error or PC compatibility issues.  
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Troubleshooting Flowchart 

�����

�����	�

��	��

	����
�����	�����������������
�
�	��������������������	�

�������������������

�����	������������
������������������

����

��� �� ��

����

���

����

�� ���

��	����� �������	��

������������	���

��������
	��������������	����
���	�����������
	����	
��
	����	�������	�����������	����

��������
	��������������	����
���	��������������	����	������
	�����������	����

������������	������������	
����
��	�������������
������ 
!
����	�����	�����������	����

��� ��

�����	���������	�������
�����
���	�������������������������	�
����������	�����������	����

�����������������

���

�	�����	��������������������������
���������	����������	��������� ���
��������������������������!�

��

������������������������������
�����������������������	������
�	
	�����������

����

��� ��

�� ���

�	���������������������
������	����
����������
���������	������������
�������	��������������
	�����������	����

��������������������	������
������	�
�����������	������
����������������������������
�	������������������������
������������	�������	���

����

��� ��

�������������������	�������	����
�������������������� ��������
	�������	���!��	�����������	����

����

 


